SETTING MIKROTIK RB951-2N

June 6, 2013 at 1:58 am Leave a comment


SETTING MIKROTIK RB951-2N

Fana Akbarkan

05 Juni 2013

 

PENDAHULUAN
Alat dan bahan :

  • Mikrotik RB951-2N
  • laptop, linux installed
  • kabel LAN 2 buah
  • hp android

Ada beberapa permasalahan yang harus diselesaikan

  • memakai IP statis, hanya dipakai 20
  • dhcp server di disable
  • blok facebook
  • blok internet, hanya lan saja

 

ISI

Sebelum melakukan pemasangan, desain dulu konfigurasi jaringannya. Kurang lebih seperti ini :

 

konfigurasi_rb951

konfigurasi_rb951

 

Langsung saja, ke titik permasalahan yang akan diatasi, yaitu :

  1. Memakai IP statis, hanya dipakai 20 IP

Misalnya seperti ini

  • IP address yang digunakan 192.168.88.1 sampai 192.168.88.20 dan ip yang tidak digunakan di blok.

 

  • Maka sisa ip yang tidak digunakan adalah 192.168.88.21 ā€“ 192.168.88.255.

 

 

Caranya adalah sebagai berikut

  1. Buat dulu group address-list yang akan di block, yaitu 192.168.88.21 ā€“ 192.168.88.255. Kodenya sbb :
  • :for i from 21 to 255 do={/ip firewall address-list add address=”192.168.88.$i” list=ip_tidak_dipakai disabled=no}

 

  1. Buat new firewall rules untuk kelompok address-list tersebut di atas. Semua paket yang melewati interface ether1-gateway akan di drop. Scriptnya sbb :
  • /ip firewall filter add chain=forward out-interface=ether1-gateway src-address-list=ip_tidak_dipakai action=drop comment=blok_ip_tidak_dipakai
  1. Cobalah gunakan ip antara 21 s/d 255, pasti no koneksi internet.
  2. IP 21 s/d 255 hanya terkoneksi secara LAN.

 

  1. DHCP di disable

Sebenarnya ini tidak perlu di setting, dibiarkan saja, karena meskipun ada client yang konek, dia tidak akan dapat koneksi internet, hanya mendapat koneksi lokal saja.

 

  1. Block facebook

Hampir sama sebenarnya dengan filter sebelumnya. Caranya sebagai berikut :

  1. Buat dulu group ip mana yang akan di blacklist, kita misalkan IP 192.168.88.11 s/d IP 192.168.88.20. Kodenya sebagai berikut :
  • :for i from 10 to 20 do={/ip firewall address-list add address=”192.168.88.$i” list=block_facebook disabled=no}

 

  1. Buat new firewall rules untuk group tersebut di atas. Semua paket yang menuju www.facebook.com akan di DROP. Kodenya sebagai berikut :
  • /ip firewall filter add chain=forward src-address-list=block_facebook dst-address=173.252.110.27 out-interface=ether1-gateway action=drop comment=blok_fsbuk
  1. Cobalah memakai 192.168.88.11 dan browsing facebook, pasti tidak bisa.

 

 

  1. Blok internet, hanya LAN saja

Dengan settingan sekarang ini, IP address 192.168.88.11 s/d 192.168.88.255 bisa terkoneksi ke jaringan LAN namun tidak dapat mengakses internet. Untuk lebih jelasnya pembagian IP nya sebagai berikut.

No Nama group IP List IP address Kemampuan
1 Bebas akses 192.168.88.1 s/d 192.168.88.10 bebas
2 Block facebook 192.168.88.11 s/d 192.168.88.20 LAN, internet bisa kecuali facebook
3 Block internet 192.168.88.21 s/d 192.168.88.255 LAN saja

 

 

PENUTUP

Untuk melakukan blocking koneksi berdasarkan IP address menggunakan mikrotik sangat mudah.

 

 

 

Tambahan

  1. Blok download berdasarkan extensi file

Beberapa kantor melakukan bloking untuk download file tertentu, caranya menggunakan firewall layer 7 :

  • Buat dulu list extensi yang akan di blok, misalnya avi, kodenya sebagai berikut :
  • /ip firewall layer7-protocol add name=”NO avi” regexp=”^.*get.+\\.avi.*\$”
  • Lalu diikuti penambahan filternya, kodenya sebagai berikut :
  • /ip firewall filter add chain=forward action=drop layer7-protocol=”NO avi” out-interface=ether1 comment=”BLOK DOWNLOAD FILE AVI”

 

Beberapa kantor bahkan memiliki aturan lebih keras lagi:

  • kode inisiasi
  • /ip firewall layer7-protocol add name=”EKSTENSI” regexp=”^.*get.+\\.(exe|asf|mov|wmv|mpg|mpeg|mkv|avi|flv|wav|rm|mp3|mp4|ram|rmvb|daa|iso|nrg|vcd|mp2|3gp|mpe|qt|raw|wma|ogg).*\$”
  • kode filter
  • /ip firewall filter add chain=forward action=drop layer7-protocol=”EKSTENSI” out-interface=ether1 comment=”BLOK DOWNLOAD FILE”

 

Sumber :

  • Saya mengambil beberapa artikel dari internet. Terima kasih

 

 

Fana Akbarkan

081938482244

03179530730

http://www.berselancar.com

 

Advertisements

Entry filed under: network. Tags: , , , , .

Menghidupakan Kembali TL-WR741ND | Debricking Blok facebook dengan iptables

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Trackback this post  |  Subscribe to the comments via RSS Feed


VIEWED - Dilihat

  • 88,441 times - kali

CALENDAR – Kalender

June 2013
M T W T F S S
« Feb   Jul »
 12
3456789
10111213141516
17181920212223
24252627282930

ARCHIVES – Arsip

ads1

(adsbygoogle = window.adsbygoogle || []).push({});

%d bloggers like this: